You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

31 lines
653 B
Nix

{
description = "Config generation for HAProxy";
inputs = {
nixpkgs.url = "github:NixOS/nixpkgs/master";
utils.url = "github:numtide/flake-utils";
};
outputs = { self, utils, nixpkgs }:
utils.lib.eachDefaultSystem
(system: let
pkgs = import nixpkgs {
inherit system;
};
in {
packages.default = pkgs.stdenv.mkDerivation {
name = "haproxy-noop";
unpackPhase = "true";
buildPhade = "touch .noop";
installPhase = ''
mkdir -p $out
touch $out/.noop
'';
};
}) // {
nixosModule = {config, lib, pkgs, ...}: {
};
};
}