summary refs log tree commit diff
path: root/app/Cargo.toml
diff options
context:
space:
mode:
authorAshelyn Rose <git@ashen.earth>2025-02-22 20:23:43 -0700
committerAshelyn Rose <git@ashen.earth>2025-02-22 20:23:43 -0700
commitddbef5d475951dfd9157221b611e7d1ac06da86b (patch)
treef143f1dfc0b61c97aeb513c9bfa540260b3e753d /app/Cargo.toml
parent5c6a049c4c962be7bf889897b16a1778bbe63819 (diff)
Incredibly messy persistence refactor
Stores account information in the app data folder, and account credentials in the OS keychain
Diffstat (limited to 'app/Cargo.toml')
-rw-r--r--app/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/app/Cargo.toml b/app/Cargo.toml
index 31bce47..e0def75 100644
--- a/app/Cargo.toml
+++ b/app/Cargo.toml
@@ -11,6 +11,8 @@ crate-type = ["staticlib", "cdylib", "rlib"]
 tauri-build = { version = "2", features = [] }
 
 [dependencies]
+dirs = "6.0.0"
+keyring = { version = "3", features = ["apple-native"] }
 reqwest = { version = "0.12.12", features = ["json"] }
 serde = { version = "1", features = ["derive"] }
 serde_json = "1"
@@ -19,5 +21,6 @@ tauri-plugin-opener = "2"
 tauri-plugin-deep-link = "2"
 tauri-plugin-single-instance = {version = "2", features = ["deep-link"] }
 tokio = "1.43.0"
+toml = "0.8.20"
 url = "2.5.4"
 uuid = {version="1.13.1", features= ["v4"] }