summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAshelyn Rose <git@ashen.earth>2024-10-26 02:20:32 -0400
committerAshelyn Rose <git@ashen.earth>2024-10-26 02:20:32 -0400
commit130669793dfb77b286a26a373378b4d1f2be837c (patch)
treeb2867473b4610e3f79c3098bf661435c25fcee5c /Cargo.toml
parent2eee33d2a2042b209dd5f9ef4b7314ea81a33360 (diff)
Very basic rocket db state and session lookup (with hardcoded session id)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2529b4a..685851f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,5 +5,8 @@ edition = "2021"
 
 [dependencies]
 joinrs = { git = "https://git.tempest.dev/ashe/joinrs", version = "0.0.1" }
-sqlx = { version = "0.8.2", features = ["postgres", "runtime-tokio"] }
+rocket = { version = "0.5.1" , features = ["json"] }
+sqlx = { version = "0.8.2", features = ["postgres", "runtime-tokio", "uuid", "time"] }
+time = { version = "0.3.36", features = ["serde-human-readable"] }
 tokio = { version = "1.40.0", features = ["fs", "io-std", "rt"] }
+uuid = { version = "1.11.0", features = ["v4", "serde"] }