summary refs log tree commit diff
path: root/opcode_proc/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'opcode_proc/Cargo.toml')
-rw-r--r--opcode_proc/Cargo.toml12
1 files changed, 12 insertions, 0 deletions
diff --git a/opcode_proc/Cargo.toml b/opcode_proc/Cargo.toml
new file mode 100644
index 0000000..9c17800
--- /dev/null
+++ b/opcode_proc/Cargo.toml
@@ -0,0 +1,12 @@
+[lib]
+proc-macro = true
+
+[package]
+name = "opcode_proc"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
+syn = {version = "2.0.90", features = ["full"] }
+proc-macro2= "1.0.92"
+quote = "1.0"